본 게시물은 개인적인 의견으로 작성되었으니 절대적인 정보가 아닐 수 있습니다. 참고만 하시고 궁금한 사항이 있으시면 연락주세요.

티스토리 뷰

상위버전으로 마이그레이션시 호환성수준의 이슈가 발생한다. 아래와 같은 문서를 참고하셔서 마이그레이션하는데 도움이 될 것 같다.

업그레이드 어드바이저를 설치하여 수행하면 아래와 같은 내용을 가이드 하는 것을 있다.

보통 SQL 2000 에서 상위 버전으로 업그레이드 할때 이슈가 가장 같다.

예전 개발하던 사람들의 습관으로 만들어진 내용일 뿐이다. .

   

[참고문서]

ALTER DATABASE Compatibility Level (Transact-SQL)

https://technet.microsoft.com/en-us/library/bb510680(v=sql.105).aspx

   

mpatibility-level setting of 80

Compatibility-level setting of 90

Possibility of impact

For locking hints in the FROM clause, the WITH keyword is always optional.

With some exceptions, table hints are supported in the FROM clause only when the hints are specified with the WITH keyword. For more information, see FROM (Transact-SQL).

High

The *= and =* operators for outer join are supported with a warning message.

These operators are not supported; the OUTER JOIN keyword should be used.

High

   



<추가 2016.5.12>

데이터베이스 엔진 업그레이드 문제

https://msdn.microsoft.com/ko-kr/library/ee240650(v=sql.120).aspx

댓글
댓글쓰기 폼
1 ··· 26 27 28 29 30 31 32 33 34 ··· 119